home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / sys-libs / zlib-1.2.3 / zlib-1.2.3.ebuild < prev   
Text File  |  2005-10-13  |  2KB  |  71 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/zlib-1.2.3.ebuild,v 1.6 2005/07/22 06:22:47 hardave Exp $
  4.  
  5. inherit eutils flag-o-matic
  6.  
  7. DESCRIPTION="Standard (de)compression library"
  8. HOMEPAGE="http://www.gzip.org/zlib/"
  9. SRC_URI="http://www.gzip.org/zlib/${P}.tar.bz2
  10.     http://www.zlib.net/${P}.tar.bz2"
  11.  
  12. LICENSE="ZLIB"
  13. SLOT="0"
  14. KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
  15. IUSE="build"
  16.  
  17. RDEPEND=""
  18.  
  19. pkg_setup() {
  20.     tc-export CC RANLIB
  21.     export AR="$(tc-getAR) rc"
  22. }
  23.  
  24. src_unpack() {
  25.     unpack ${A}
  26.  
  27.     cd "${S}"
  28.     # Make sure we link with glibc at all times
  29.     epatch "${FILESDIR}"/${PN}-1.2.1-glibc.patch
  30.     # Needed for Alpha and prelink
  31.     epatch "${FILESDIR}"/${PN}-1.2.1-build-fPIC.patch
  32.     # Only export global symbols, bug #32764
  33.     epatch "${FILESDIR}"/${PN}-1.2.2-mapfile.patch
  34.     # The configure script can be kind of dumb #55434
  35.     epatch "${FILESDIR}"/${PN}-1.2.1-configure.patch
  36.     # fix shared library test on -fPIC dependant archs
  37.     epatch "${FILESDIR}"/${PN}-1.2.1-fPIC.patch
  38. }
  39.  
  40. src_compile() {
  41.     ./configure --shared --prefix=/usr --libdir=/$(get_libdir) || die
  42.     emake || die
  43. }
  44.  
  45. src_install() {
  46.     einstall libdir="${D}"/$(get_libdir) || die
  47.     rm "${D}"/$(get_libdir)/libz.a
  48.     insinto /usr/include
  49.     doins zconf.h zlib.h
  50.  
  51.     if ! use build ; then
  52.         doman zlib.3
  53.         dodoc FAQ README ChangeLog
  54.         docinto txt
  55.         dodoc algorithm.txt
  56.     fi
  57.  
  58.     # we don't need the static lib in /lib
  59.     # as it's only for compiling against
  60.     dolib libz.a
  61.  
  62.     # all the shared libs go into /lib
  63.     # for NFS based /usr
  64.     into /
  65.     dolib libz.so.${PV}
  66.     ( cd "${D}"/$(get_libdir) ; chmod 755 libz.so.* )
  67.     dosym libz.so.${PV} /$(get_libdir)/libz.so
  68.     dosym libz.so.${PV} /$(get_libdir)/libz.so.1
  69.     gen_usr_ldscript libz.so
  70. }
  71.